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1. Information about Q-LavHA 

Accurate simulation of lava flow extent is essential information for scientists or stakeholders 

confronted with imminent or long-term lava flow hazard from basaltic volcanoes. Knowing what can 

be the area inundated by a potential or imminent lava flow can improve their understanding of the 

spatial distribution of lava flow hazard, influence their land use decisions and support evacuation 

planning during a volcanic crisis. 

Q-LavHA (Quantum-Lava Hazard Assessment) (Mossoux et al., 2016) is a freeware plugin which 

simulates channelized ʻaʻā lava flow inundation probability from one or regularly distributed eruptive 

vents on a Digital Elevation Model (DEM). It combines existing probabilistic and deterministic models 

(Felpeto et al., 2001; Harris and Rowland, 2001) and proposes some improvements to calculate the 

probability of lava flow spatial propagation and terminal length.  

This user manual is provided to discuss the technical aspect of the plugin. We recommend you to 
carefully read the entire manual before starting any simulation. Make sure to prepare your input data 
such as described in the bellow section and fill correctly the required input parameters into the plugin 
before starting any simulation. For a more scientific description, please have a look at the related 
scientific paper written by Mossoux et al. in 2016 entitled “Q-LavHA: A flexible GIS plugin to simulate 
lava flows” (Computers and Geosciences). 

2. Installation instructions 

- Register on the Q-LavHA website (http://we.vub.ac.be/en/q-lavha): Download>Plugin>Register 

now.  After registration, we will provide you a link to download the .zip file that contains the plugin. 

- Install QGIS (https://www.qgis.org/en/site/forusers/download.html). The minimum required 

version of QGIS is 3.0. 

- Install the Q-LavHA .zip file in QGIS: Plugins>Manage and Install plugins>Install from ZIP>…>Install 

Plugin. Do not unzipped the Q-LavHA file as QGIS required an .zip file to install a new plugin.  

- Verify the plugin is well installed: Plugins>Manage and Install plugins>Installed>Q-LavHA checked. 

If needed, restart QGIS. 

http://we.vub.ac.be/en/q-lavha
https://www.qgis.org/en/site/forusers/download.html
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3. Prepare your data 

DIGITAL ELEVATION MODEL (DEM) 

The DEM is a .asc or .tiff file that has to be projected in UTM. To avoid simulations to be stuck in 

abnormal depressions, it is recommended to fill the nodata value and the sinks during a pre-processing 

manipulation. 

WHERE TO DOWNLOAD A DEM? 

SRTM are Digital Elevation Model images of the year 2000 available for the entire world. The data are 

freely available on the following website: srtm.csi.cgiar.org/SELECTION/inputCoord.asp or 

https://earthexplorer.usgs.gov/ after registration on their website.  

REPROJECTION 

Q-LavHA is working with DEMs projected in UTM. To reproject a DEM that has a geographic coordinate 

system (lat/lon) to a UTM projected coordinate system (m): QGIS>Raster>Projections>Wrap 

(Reproject):  

- Input: the DEM with a geographic coordinate system (lat/lon). 

- Source CRS: select>in the second panel select under Geographic Coordinate System WGS 84. 

- Target CRS: select>in the second panel select under Projected Coordinate System the adapted 

WGS84/UTM zone of your study area.  

- Resampling method to use: Bilinear 

- Reprojected: Save to File> name of the new DEM that will be produced. 

 

UTM zone map for the world 

http://srtm.csi.cgiar.org/SELECTION/inputCoord.asp
https://earthexplorer.usgs.gov/
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FILL NODATA 

Fill in nodata values  present in the DEM is important to avoid the simulation to stop: 

QGIS>Raster>Analysis>Fill nodata: 

- Input: the DEM.  

- Filled: Save to File>Name of the new DEM. 

FILL SINK 

Fill abnormal depressions present in the DEM is important to avoid the simulation to be stuck: 

QGIS>Processing>Toolbox>SAGA>Terrain Analysis – Hydrology>Fill sinks: 

- DEM: the DEM.  

- Filled DEM: Save to File>Name of the new DEM as a .sdat 

After running the plugin:  

- Right click on the output layer>Export>Save as: 

o Format: GeoTIFF 

o File name: name of the new DEM 

DEM EXTENT 

Keep in mind that the total number of pixels of the DEM and therefore its extent and spatial resolution 

control the processing time of the simulation. Limit the extent of the DEM to avoid to over-load the 

plugin: QGIS>Raster>Extraction>Clip raster by extent. 
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VENT VECTOR LAYER 

To make the simulations easier, the user can produce for each eruption vent a vector layer from which 

Q-LavHA automatically will extract the coordinates of its first object. To produce your own vent vector 

layer: 

- ACTIVATE THE NEEDED TOOLBARs: 

▪ QGIS>Menu>View>Toolbars>activate 

▪ Manage Layers Toolbar 

▪ Digitizing Toolbar 

- CREATE THE VENT VECTOR LAYER by creating a new shapefile: click on the new shapefile 

layer icon or Layer > Create Layer > New Shapefile Layer 

▪ Geometry type: point, line or polygon. 

▪ Specify CRS: WGS84/UTM zone of the study area. 

 

- DRAW THE VENT: Start editing the layer:  

▪ Select the layer you want to edit. 

▪ Edit the layer by clicking on the ‘toggle editing’ button (or right click > Toggle Editing). 

▪ Click on the ‘add polygon feature’ button and draw the polygon. 

o Left click to draw the polygon feature. 

o Backspace to erase a vertex.  

o Right click to end the drawing.  

o ID= 1  

▪ Click on the ‘save layer edits’ button. 

▪ Stop editing mode by clicking again on the ‘toggle editing’ button. 

Toggle editing Add polygon features Save layer edits New field 

    

 

REAL LAVA FLOW 

In order to assess the accuracy of the simulated channelized ʻaʻā lava flow, a fitness index (FI) can be 

calculated. If the option is activated, the simulated lava flow will be compared to a real lava flow. The 

real lava flow has to be a .asc or .tiff file where a ‘1’ value is assigned to all pixels corresponding to the 

real lava flow. The resolution of the real lava flow has to be the same as the DEM resolution. 

- CREATE THE REAL LAVA FLOW by creating a new shapefile: click on the new shapefile layer 

icon or Layer > Create Layer > New Shapefile Layer 

▪ Geometry type: polygon. 

▪ Specify CRS: WGS84/UTM zone of the study area. 

▪ New field: name=value/ type=whole number>add to fields list. 

 

- DRAW THE REAL LAVA FLOW: Start editing the layer:  
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▪ Select the layer you want to edit. 

▪ Edit the layer by clicking on the ‘toggle editing’ button. 

▪ Click on the ‘add polygon feature’ button and draw the polygon. 

o Left click to draw the polygon feature. 

o Backspace to erase a vertex.  

o Right click to end the drawing.  

o ID= 1 and value= 1. 

▪ Click on the ‘save layer edits’ button. 

▪ Stop editing mode by clicking again on the ‘toggle editing’ button. 

 

- CONVERT the shapefile to a raster 

▪ Open the attribute table: select the layer>right click>open attribute table. 

▪ Verify that there is a field value=1. If not:  

o Start the editing mode of the attribute table by clicking on the ‘toggle editing 

mode’ button. 

o Add a column ‘Value’ to the attribute table: click on the ‘new field’ button. 

• Name: value. 

• Type: whole number (integer). 

• Length: 1. 

o Type ‘1’ in the new field. 

o Click on the ‘save layer edits’ button. 

o Stop editing mode by clicking again on the ‘toggle editing’ button. 

▪ Convert the shapefile to a raster: Raster>Conversion>Rasterize:  

o Input layer: shapefile of the real lava flow (.shp). 

o Field to use for a burn-in value: the column ‘value’ in the attribute table. 

o Output raster size units: georeferenced units. 

o Width/Horizontal resolution: DEM resolution on which the simulations are 

realized. To know what is that value: open the DEM layer 

properties>properties>Pixel size. 

o Height/Vertical resolution: DEM resolution on which the simulations are realized. 

o Output extent: Use Layer Extent>Use Extent from>the real lava flow .shp  

o Assign a specified nodata value to output bands: the NoData value of the DEM that 

you are using. To know what is that value: open the DEM layer 

properties>transparency>No data value. 

o Rasterized: Save to file>name of the output file (.tif). 

4. Open Q-LavHA 

To open the plugin in the QGIS interface, press on the Q-LavHA icon in the QGIS tool bar. 
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5. Define the Q-LavHA parameters 

FIRST TAB – VENT LOCATION:  Provide information about the local topography and the 

eruption location. 

 

DEM SELECTION 

Topography plays an important role to determine where a lava flow front will propagate. Therefore, a 

Digital Elevation Model (DEM) must be implemented in Q-LavHA.  

The DEM must be projected in UTM and it is recommended to FILL THE SINKS to avoid the simulation 

to be stuck in abnormal depressions present in the DEM. LIMIT THE EXTENT of the DEM to avoid to 

over-load the plugin (see above instructions on how to prepare your data).  

Finally, Q-LavHA requires DEM in an .ASC FORMAT. The user can select a DEM .tiff file which will be 

automatically converted by the plugin to an .asc format. Do not use another software to produce the 
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.asc file. Leaving Q-LavHA to convert the .tiff file into an .asc format insure you to have the required 

file structure to run the simulations: 

- Convert the .tiff file into an .asc format: Q-LavHA>FIRST TAB: Select DEM>Change the file type in 
the lower right corner of the window that pops up to GeoTiff>select the DEM.  

VENT TYPE 

The eruption source(s) can be defined in Q-LavHA as a point, a line or a surface area. The vent 

coordinates can be inserted manually or can be extracted from an already existing shapefile.  

MANUALLY 

- Base on the type of vent that must be simulated, add the UTM coordinates manually. For a POINT, 

select Point and fill in coordinate 1. For a LINEAR FISSURE, select linear fissure and fill in coordinate 

1 to 2. For a SURFACE AREA, select surface area and fill in coordinate 1 to 4. For polygons, the code 

automatically recalculates the extent of the source zone to the largest-fit rectangle. 

- If you do not know the coordinates of the vent: before opening Q-LavHA, install the plugin 

COORDINATE CAPTURE: Plugins>Manage and Install plugins>Not Installed>Coordinate Capture. 

When the coordinate capture plugin is installed: Start capture>point on the DEM to the 

desired location. The tool shows coordinates which remain displayed, even after moving 

the cursor.  

FROM AN EXISTING SHAPEFILE 

- The starting coordinates can be extracted from an already existing shapefile (see above 

instructions on how to prepare your data). Select the option CHOOSE LAYER and choose the 

desired vector layer (point, line or polygon UTM projected) from the LIST of the layers opened in 

the working space or BROWSE through your directory to find the desired layer. This layer will 

automatically open in the working space. The coordinates of the first feature of that layer will be 

extracted.  

PDF MAP 

A probability density function map (PDF MAP) can be introduced and used to make simulations on a 

large area. A PDF map attributes a probability of vent opening to every pixel within the considered 

area between zero and one c). A PDF map can be produced with QVAST (Bartolini et al., 2013). Based 

on a specific threshold (MINIMUM PDF VALUE TO SIMULATE), the code analyzes successive pixels till 

encountering a pixel with a value higher or equal to the threshold and starts simulations. This minimum 

PDF value enables to avoid simulating lava for pixels with no or negligible chance to host an eruption 

site. ‘No Data’ pixels are ignored. Result of each individual simulation is weighted by the PDF value of 

the source pixel. 

- If the “Use PDF Map” option is chosen, the user selects the probability density function map (.asc 

or .tiff file) and introduces the minimum PDF value for the simulation. Pay attention, the PDF file 

will be automatically transformed into an ascii file if a .tiff is uploaded. To choose a .tiff file, change 

the file type on the lower right in the lower right corner of the window that pops up to GeoTiff.  
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DISTANCE BETWEEN THE VENTS 

For linear fissure, surface area and PDF map, simulations are not realized at each pixel. The user can 

define, in the DISTANCE BETWEEN THE VENTS (m) box, the spacing between successive punctual 

simulations. Provide a multiple of the DEM pixel size (e.g. 180 m or 900 m if the DEM resolution is of 

90 m) 

IMPORT PARAMETERS 

The user can IMPORT PARAMETERS used during previous simulations if a parameter file has been 

previously saved (.qlc) (see third tab – output files).  

 

 

SECOND TAB – LAVA FLOW PARAMETERS:  Provide information about the lava flow 

characteristics such as height and length. 
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LAVA FLOW PROPAGATION 

A lava flow is a viscous fluid with yield strength. For that reason, it does not follow only the steepest 

path but is able to propagate laterally, fill depressions and overcome topographical obstacles. 

Corrective factors are included enabling the lava to overcome these small topographical obstacles or 

pits. 

- Hc factor is always added to the elevation of the pixel at which the lava is located. This enable to 

simulate the lava thickness (Felpeto et al., 2001). It is a float number (m). See Q-LavHA scientific 

paper (Mossoux et al., 2016) for more details. 

- Hp is also a topographical corrective factor that is only used when Hc is not enough. It replaces 

Hc (float number) (m). If both Hc and Hp are used, the Hp value needs to be larger than Hc to be 

effective. See Q-LavHA scientific paper (Mossoux et al., 2016) for more details. 

 

 
(Mossoux et al. 2016) 

 

- H16: If the lava flow line reaches a pit, which is too deep to be overcome by the corrective factors 

Hc and Hp, Q-LavHA includes the option to consider the 16 next surrounding pixels (H16). If the 

lava flow line can propagate to one of the 16 surrounding pixels, it continues its path. If not, the 

simulation stops. It is recommended to activate this option. See Q-LavHA scientific paper (Mossoux 

et al., 2016) for more details. 

- PROBABILITY TO THE SQUARE: this option narrows results spatially because the chance to take 

the steepest slope is increased. The second power induces that the pixel with the highest elevation 

differences gets a higher probability. Therefore, the flow line is more likely to follow the steepest 

slope path. It is recommended to use it, especially on gentle slopes. See Q-LavHA scientific paper 

(Mossoux et al., 2016) for more details. 

LAVA FLOW LENGTH CONSTRAINTS 

Lava emplacement is controlled by a complex interplay between mainly the effusion rate, underlying 

topography, lava viscosity, yield strength, cooling processes, morphology and propagation dynamics. 

However, many of these parameters are often not available or poorly constrained for a specific lava 

flow, they are difficult to predict and they vary between eruptions. To enable short-term forecasting, 
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alternatives must be found. In this context, Q-LavHA proposes four alternatives to terminate a flow 

line. 

- MANHATTAN LENGTH (m): Q-LavHA consider the Manhattan length as the traveled distance 

covered by the lava flow line. It considers each visited pixel and loop realized by the flow line. 

The iteration stops when that distance is reached.  

 
 

- EUCLIDEAN LENGTH (m): The Euclidean represents the crow-flies distance between the point 

where the simulation starts and the front of the flow line. The simulation stops when that distance 

is reached.  

 
 

- DECREASING PROBABILITY: Because the length of each lava flow is not constant for a given 

volcano, it can be assumed that the probability of reaching a certain length can be expressed by a 

decreasing cumulative density function following a normal distribution (𝜑) (Bonne et al., 2008). 

This third option allows weighting the probability of lava inundation of each pixel along a lava flow 

line based on a decreasing cumulative density function. To use this equation, the user must to 

define the average length (m) and the standard deviation (m) of the historical lava flows of the 

volcano. The simulation stops when the flow line reaches a maximum Euclidean length equal to 

(mean + 3 * std). The final probability expressed by each pixel is a result of a calibration of the 

pixels with a decreasing cumulative distribution function. 
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- FLOWGO is a cooling-limited model. It is recommended to use this model only if the constraints of 

the lava flows physic-rheological properties are well defined. The pre-defined advanced 

parameters are from Harris & Rowland (2001) on Etna flows. The key parameters are effusion rate, 

lava initial viscosity, phenocryst content and channel ratio. The lava flow stops when at least one 

of the following conditions holds: (1) its velocity is zero, (2) the lava core temperature reaches the 

solidus or (3) the yield strength at the base of the channel is greater than the downhill stress. 

Important to note that whatever the stopping length constraint selected, if Q-LavHA reaches an area 

surrounded by more or equal to four NoData pixels (a lake, a sea) or the edge of the DEM, simulations 

stops.  

SIMULATION 

The result obtained after a simulation is an integration of all the lava flow lines computed from one or 

multiple eruptive vents. The number of lava flow lines computed from one vent is defined by the 

NUMBER OF ITERATIONS that must be specified in Q-LavHA. After each iteration, a probability to be 

inundated (1/number of iterations) is attributed to each pixel that is part of the obtained flow line. 

This probability is added up to the output which allows defining the final pixel probability to be 

inundated.  

A sufficiently high number of iterations (>1500 for a point simulation) is required to obtain stable and 

representative results. 

With line or surface simulations, representative of fissure eruptions and clusters of closely spaced 

vents, simulations are produced for regularly spaced vent locations along the line or over the surface. 

All simulations are then combined and divided by the total number of vents simulated. Because for 

these simulations, the lava flow lines overlap each other, the NUMBER OF ITERATIONS can be reduced. 

This also enables to reduce the computation time of these computation demanding simulations. 
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THIRD TAB – OUTPUT FILES:  Provide information about the generated output files 

 

LAVA PROBABILITY 

THE THRESHOLD is the minimum probability considered in the simulation result (%). Only pixels having 

an inundation probability higher than the user defined threshold are displayed on the output map. 

Probabilities below that threshold, i.e. pixels that are flooded by a limited number of flow lines, are 

then considered as noise and are neglected. 

FITNESS INDEXES 

To assess the accuracy of the simulated lava flow, fitness indexes can be calculated. The indexes 

compare the simulated lava flow to the real lava flow outline. To calculate these indexes, the user has 

to activate the Fitness Index option and to introduce a raster .asc or .tiff outline of the real lava flow 

(e.g. the lava flow of reference) (see above instructions on how to prepare your data). Pay attention, 

the file will be automatically transformed into an ascii file if a .tiff is uploaded. To choose a .tiff file, 

change the file type in the lower right corner of the window that pops up.  
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The fitness indexes are written in the -summary file at the end of the simulation.  

- TRUE POSITIVE (TP): corresponds to the overlapping area between the simulated and real lava 

flow. The TP varies between zero and one. The closer it gets to one, the more important is the 

overlap and the better the simulated lava flow corresponds to the real lava flow. See Q-LavHA 

scientific paper (Mossoux et al., 2016) for more details. 

- FALSE POSITIVE (FP): corresponds to the over-simulated lava flow area. The FP varies between 

zero and one. The closer it gets to one, the more important is the over-simulated area. See Q-

LavHA scientific paper (Mossoux et al., 2016) for more details. 

- FALSE NEGATIVE (FN): corresponds to the under-simulated lava flow area. The FN varies between 

zero and one. The closer it gets to one, the more important is the under-simulated area. The closer 

the FALSE NEGATIVE gets to zero, the best as this means that a large part of the real lava flow has 

been well covered by the simulation.  See Q-LavHA scientific paper (Mossoux et al., 2016) for more 

details. 

The sum of these three indexes equals one and can be used to optimize the set of input parameters 

chosen to reproduce a lava flow. Based on the precautionary principle in a context of hazard 

assessment, we consider it less problematic to overestimate the future inundated area rather than 

to underestimate it. The true positive must be maximized and the false negative should be 

minimized.  

 
(Mossoux et al. 2016) 

- COMPOSITE SCORE: To compare results from the different simulations scenarios more easily, a 

weighted composite score was developed (CS). Using exponents, this index gives high importance 

to the presence of both high True Positive (correctly delineated) and very low False Negative (area 

underestimated), each index being crucial for effective use in risk management. When the area 

simulated matches perfectly the deposits mapped in the field, the composite score equals 100 (i.e. 

TP=1, FP and FN=0). When it mismatches the actual flow completely (i.e. TP=0 and FP + FN=1), the 

composite score equals 0.  

𝐶𝑆 = 𝑇𝑃 ∗ (( 1 − 𝐹𝑃)1/2) ∗ ((1 − 𝐹𝑁)2) ∗ 100   

- CUMULATIVE PROBABILITY WITHIN THE LAVA FLOW (CUMin): represents the cumulative 

probability of the pixels located within the real lava flow. Instead of focussing on the outline of the 

lava flow such as previous indexes, this index emphasis on the location of the inundation 

probabilities pixels. This index varies between zero and one. The higher the index, the best.  
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𝐶𝑈𝑀𝑖𝑛 = 100 / 
∑ 𝑙𝑎𝑣𝑎 𝑓𝑙𝑜𝑤 𝑖𝑛𝑢𝑛𝑑𝑎𝑡𝑖𝑜𝑛 𝑝𝑟𝑜𝑏𝑎𝑏𝑖𝑙𝑖𝑡𝑦  𝑤𝑖𝑡ℎ𝑖𝑛 𝑡ℎ𝑒 𝑟𝑒𝑎𝑙 𝑙𝑎𝑣𝑎 𝑓𝑙𝑜𝑤

∑ 𝑙𝑎𝑣𝑎 𝑓𝑙𝑜𝑤 𝑖𝑛𝑢𝑛𝑑𝑎𝑡𝑖𝑜𝑛 𝑝𝑟𝑜𝑏𝑎𝑏𝑖𝑙𝑖𝑡𝑦 𝑜𝑓 𝑡ℎ𝑒 𝑒𝑛𝑡𝑖𝑟𝑒 𝑠𝑖𝑚𝑢𝑙𝑎𝑡𝑖𝑜𝑛
 

 

- CUMULATIVE PROBABILITY OUTSIDE THE LAVA FLOW (CUMout): represents the cumulative 

probability of the pixels located outside the real lava flow. It is the opposite of previous index. The 

lower the index, the best.  

𝐶𝑈𝑀𝑜𝑢𝑡 = 1 −   𝐶𝑈𝑀𝑖𝑛 

OUTPUT FILE 

The output produced by Q-LavHA is a raster map expressing the probability of a pixel to be flooded by 

lava. It is presented in an .asc raster format and is added as a new layer to the active QGIS project. A 

summary file is simultaneously produced to recall the parameters used during the simulation. 

- Define the OUTPUT path and name. 

EXPORT PARAMETERS 

To enable the user to reuse the input parameters of a simulation and to upload them more easily 

during a next simulation, the user can save the input parameters in a .qlc file which records all the 

input parameters of that specific simulation.  
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FOURTH TAB – ADVANCED SETTINGS:  Realize if desired a sensitivity test on specific input 

parameters 

 

If requested, the user can realize a sensitivity test of one parameter at a time. As for a standard 

simulation, the user is requested to fill in all the input parameters of the “vent location”, “lava flow 

parameter” and “output files” tabs. When completed, the user can:  

- Activate the sensitivity test 

- PARAMETER: Select the parameter on which to realize the analysis. A sensitive analysis can only 

be realized on a specific parameter when the corresponding option has been selected in the 

previous tabs. The value that is displayed on the tab will be overwritten by the start, stop and step 

parameters provided in the sensitivity test. All other parameters will stay constant throughout the 

sensitivity analysis. 

- MINIMUM/MAXIMUM/STEP: Define the starting and stopping values as well as the step between 

the analysis. These values must be integer, except for the Hc, Hp, the FLOWGO-initial phenocryst 

mass fraction, the FLOWGO - Lava initial viscosity and the Threshold parameters where decimal 
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value up to four digits are accepted. The minimum value can not be equal to zero and must be 

smaller than the stop value.  

If user defines the minimum = 250, the maximum = 1500 and the step = 250, Q-LavHA updates the 

tested parameter with the following values= 250, 500, 750, 1000, 1250, 1500.  

- EXTRACT TABLE AND GRAPH: When the fitness index is activated in the “ouput files” tab, the user 

can activate the extract table and graph option.  This automatically generates at the end of the 

simulates a .csv table and a .png graph within the output file. These visuals extract the fitness 

indexes of all the simulations to help the user with the parameter calibration (see fitness indexes 

to know how to interpret them). 

Before starting a sensitivity analysis where the EXTRACT TABLE AND GRAPH option is activated, 

make sure to select an EMPTY FOLDER where to store the output files. 

If the folder is not empty, the code will get in trouble and if the .csv file is not closed, Q-LavHA will 

not be able to write over the existing file.  

6. Start the lava flow simulation 

- Use the RUN button (or Ctrl + R) to start the lava flow simulation. 

- Use the CANCEL button to stop the simulation. 

- If you want to refresh all the tabs, click on the RESET ALL button.  

7. Output 

When the simulation is done, QGIS displays automatically the result expressing the probability of a 

pixel to be flooded by lava.  

In the output folder tree files have been produced:  

- The simulated lava flow (.asc) 

- The projection information of the lava flow (.prj) 

- ‘…_summary’ = summary of parameters used during the simulation (.asc) 

- A fitness indexes summary table, if the extract table and graph has been activated (.csv)  

- A fitness indexes summary graph, if the extract table and graph has been activated (.png)  

 

To adapt the display of the lava flow: 
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- Right click on the layer > Properties>Symbology>Render type>Singleband pseudocolor>choose a 

color>Mode Continuous>Classify 

 

Example of a simulation realized for the 2001 Etna lava flow (Mossoux et al. 2016) 

8. Interpretation of the output 

The probabilistic lava flow map produced by Q-LavHA should be interpreted with care. Q-LavHA is a 

plugin which attempts to approach the reality of a channelized ʻaʻā lava flow inundation as accurately 

as possible. However, the outcome of the simulation depends on the quality of the DEM used and the 

selected simulation parameters. The probability of being inundated must be interpreted as having a 

higher or a lower chance to be inundated. We consequently recommend the users to interpret the 

results as the sum of the trajectories a flow can potentially follow if an eruption occurs. 

9. Processing time 

The time to compute the simulation using Q-LavHA is dependent of the size and resolution of the DEM, 

and the complexity of the simulation. Before starting any complex simulation, it is recommended to 

run simple simulations. If the user realizes that some simulations could be computer demanding, do 

not hesitate to reduce the DEM extent (QGIS>Raster>Extraction>Clip raster by extent), adapt the vent 

distance spacing, the number of iterations to realize, the minimum probability to simulation, …  
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